Router>
If it has been previously configured with a hostname, it will look like this:hostname of router>
If you have just turned on the router, after it boots it will ask you if you wish to begin initial configuration. Say no. If you say
yes
, it will put you in the menu
interface. Say no
.Each mode has a set of commands available in that mode, and some of these commands are only available in that mode. In any mode, typing a question mark will display a list of the commands available in that mode.
Router>?
2.2 Unprivileged and privileged modes
When you first connect to the router and provide the password (if necessary), you enter EXEC mode, the first mode in which you can issue commands from the command-line. From here you can use such unprivileged commands asping, telnet, and rlogin.
You can also use some of the show
commands to obtain information about the system. In unprivileged mode you use
commands like, show version
to display the version of the IOS the router is running. Typing show ?
will diplay all the show
commands available in the mode you
are presently in.
Router>show ?
Router>enable
Router#
3. Configuring
If you have just turned on the router, it will be completely unconfigured. If it is already configured, you may want to view its current configuration. Even if it has not been previously configured, you should familiarize yourself with the
show
commands
before beginning to configure the router. Enter privileged mode by issuing the
command enable
, then issue
several show
commands to see
what they display. Remember, the command show
?
will display all the show
commands
aavailable in the current mode. Definately try out the following commands:
Router#show interfaces
Router#show ip protocols
Router#show ip route
Router#show ip arp
When you enter privileged mode by using the command
enable
, you are in the top-level mode of
privileged mode, also known in this document as "parent mode." It is
in this top-level or parent mode that you can display most of the information
about the router. As you now know, you do this with the show
commands. Here you can learn the
configuration of interfaces and whether they are up or down. You can display
what IP protocols are in use, such as dynamic routing protocols. You can view
the route and ARP tables, and these are just a few of the more important
options.As you configure the router, you will enter various sub-modes to set options, then return to the parent mode to display the results of your commands. You also return to the parent mode to enter other sub-modes. To return to the parent mode, you hit
ctrl-z
.
This puts any commands you have just issued into affect, and returns you to
parent mode.Global configuration (config)
To configure any feature of the router, you must enter configuration mode. This is the first sub-mode of the parent mode. In the parent mode, you issue the commandconfig
.
Router#config
Router(config)#
As demonstrated above, the prompt changes to indicate the mode that you are now in.
In connfiguration mode you can set options that apply system-wide, also refered to as "global configurations." For instance, it is a good idea to name your router so that you can easily identify it. You do this in configuration mode with the
hostname
command.
Router(config)#hostname
ExampleName
ExampleName(config)#
As demonstrated above, when you set the name of the host with the
hostname
command, the prompt immediately
changes by replacing Router
with ExampleName
. (Note:
It is a good idea to name your routers with an organized naming scheme.)Another useful command issued from config mode is the command to designate the DNS server to be used by the router:
ExampleName(config)#ip
name-server aa.bb.cc.dd
ExampleName(config)#ctrl-Z
ExampleName#
This is also where you set the password for privileged mode.
ExampleName(config)#enable
secret examplepassword
ExampleName(config)#ctrl-Z
ExampleName#
Until you hit
ctrl-Z
(or
type exit
until you reach
parent mode) your command has not been put into affect. You can enter config
mode, issue several different commands, then hit ctrl-Z
to activate them all. Each time you hit ctrl-Z
you return to parent mode and the
prompt:ExampleName#
show
commands to verify the results of the commands you issued in config mode. To
verify the results of the ip name-server
command, issue the command show host
.Configuring interfaces
Cisco interface naming is straightforward. Individual interfaces are referred to by this convention:
media type slot#/port#
Port number refers to the port in reference to the other ports in that module. Numbering is left-to-right, and all numbering starts at 0, not at one.
For example, a Cisco 7206 is a 7200 series router with six slots. To refer to an interface that is the third port of an Ethernet module installed in the sixth slot, it would be interface ethernet 6/2. Therefor, to display the configuration of that interface you use the command:
ExampleName#show
interface ethernet 6/2
If your router does not have slots, like a 1600, then the interface name consists only of:
media type port#
For example:
ExampleName#show
interface serial 0
Here is an example of configuring a serial port with an IP address:
ExampleName#config
ExampleName(config)#interface serial 1/1
ExampleName(config-if)#ip address 192.168.155.2 255.255.255.0
ExampleName(config-if)#no shutdown
ExampleName(config-if)#ctrl-Z
ExampleName#
Then to verify configuration:
ExampleName#show
interface serial 1/1
Note the
no shutdown
command. An interface may be correctly configured and physically connected, yet
be "administratively down." In this state it will not function. The
command for causing an interface to beadministratively down is
shutdown
.
ExampleName(config)#interface
serial 1/1
ExampleName(config-if)#shutdown
ExampleName(config-if)#ctrl-Z
ExampleName#show interface serial 1/1
In the Cisco IOS, the way to reverse or delete the results of any command is to simply put
no
infront of
it. For instance, if we wanted to unassign the IP address we had assigned to
interface serial 1/1:
ExampleName(config)#interface
serail 1/1
ExampleName(config-if)#no ip address 192.168.155.2 255.255.255.0
ExampleName(config-if)ctrl-Z
ExampleName#show interface serial 1/1
Configuring most interfaces for LAN connections might consist only of assigning a network layer address and making sure the interface is not administratively shutdown. It is usually not necessary to stipulate data-link layer encapsulation. Note that it is often necessary to stipulate the appropriate data-link layer encapsulation for WAN connections, such as frame-relay and ATM. Serial interfaces default to using HDLC. A discussion of data-link protocols is outside the scope of this document. You will need to look up the IOS command
encapsulation
for more details.Routing
IP routing is automatically enabled on Cisco routers. If it has been previously disabled on your router, you turn it back on in config mode with the command
ip routing.
ExampleName(config)#ip
routing
ExampleName(config)#ctrl-Z
There are two main ways a router knows where to send packets. The administrator can assign static routes, or the router can learn routes by employing a dynamic routing protocol.
These days static routes are generally used in very simple networks or in particular cases that necessitate their use. To create a static route, the administrator tells the router operating system that any network traffic destined for a specified network layer address should be forwarded to a similiarly specified network layer address. In the Cisco IOS this is done with the
ip route
command.
ExampleName#config
ExampleName(config)#ip route 172.16.0.0 255.255.255.0 192.168.150.1
ExampleName(config)#ctrl-Z
ExampleName#show ip route
This document describes how to configure the Routing Information Protocol (RIP) on Cisco routers. From the command-line, we must explicitly tell the router which protocol to use, and what networks the protocol will route for.
ExampleName#config
ExampleName(config)#router rip
ExampleName(config-router)#network aa.bb.cc.dd
ExampleName(config-router)#network ee.ff.gg.hh
ExampleName(config-router)#ctrl-Z
ExampleName#show ip protocols
Now when you issue the
show ip
protocols
command, you should see an entry describing RIP
configuration.Saving your configuration
Once you have configured routing on the router, and you have configured individual interfaces, your router should be capable of routing traffic. Give it a few moments to talk to its neighbors, then issue the commandsshow ip route
and show ip arp
. There should now be entries
in these tables learned from the routing protocol.If you turned the router off right now, and turned it on again, you would have to start configuration over again. Your running configuration is not saved to any perminent storage media. You can see this configuration with the command
show running-config
.
ExampleName#show
running-config
You do want to save your successful running configuration. Issue the command
copy running-config startup-config
.
ExampleName#copy
running-config startup-config
Your configuration is now saved to non-volatile RAM (NVRAM). Issue the command
show startup-config
.
ExampleName#show
startup-config
Now any time you need to return your router to that configuration, issue the command
copy startup-
config running-config
.
ExampleName#copy
startup-config running-config
Example configuration
- Router>enable
- Router#config
- Router(config)#hostname N115-7206
- N115-7206(config)#interface serial 1/1
- N115-7206(config-if)ip address 192.168.155.2 255.255.255.0
- N115-7206(config-if)no shutdown
- N115-7206(config-if)ctrl-z
- N115-7206#show interface serial 1/1
- N115-7206#config
- N115-7206(config)#interface ethernet 2/3
- N115-7206(config-if)#ip address 192.168.150.90 255.255.255.0
- N115-7206(config-if)#no shutdown
- N115-7206(config-if)#ctrl-z
- N115-7206#show interface ethernet 2/3
- N115-7206#config
- N115-7206(config)#router rip
- N115-7206(config-router)#network 192.168.155.0
- N115-7206(config-router)#network 192.168.150.0
- N115-7206(config-router)#ctrl-z
- N115-7206#show ip protocols
- N115-7206#ping 192.168.150.1
- N115-7206#config
- N115-7206(config)#ip name-server 172.16.0.10
- N115-7206(config)#ctrl-z
- N115-7206#ping archie.au
- N115-7206#config
- N115-7206(config)#enable secret password
- N115-7206(config)#ctrl-z
- N115-7206#copy running-config startup-config
- N115-7206#exit
Troubleshooting
Inevitably, there will be problems. Usually, it will come in the form of a user notifying you that they can not reach a certain destination, or any destinattion at all. You will need to be able to check how the router is attempting to route traffic, and you must be able to track down the point of failure.You are already familiar with the
show
commands, both specific commands and how to learn what other show
commands are available. Some of the
most basic, most useful commands you will use for troubleshooting are:
ExampleName#show
interfaces
ExampleName#show ip protocols
ExampleName#show ip route
ExampleName#show ip arp
Testing connectivity
It is very possible that the point of failure is not in your router configuration, or at your router at all. If you examine your router's configuration and operation and everything looks good, the problem might be be farther up the line. In fact, it may be the line itself, or it could be another router, which may or may not be under your administration.One extremely useful and simple diagnostic tool is the
ping
command. Ping is an implementation
of the IP Message Control Protocol (ICMP). Ping sends an ICMP echo request to a
destination IP address. If the destination machine receives the request, it
responds with an ICMP echo response. This is a very simple exchange that
consists of:Hello, are you alive?
Yes, I am.
ExampleName#ping
xx.xx.xx.xx
If there are routers between your router and the destination you are having difficulty reaching, the problem might be at one of the other routers. Even if you
ping
a router and it
responds, it might have other interfaces that are down, its routing table may
be corrupted, or any number of other problems may exist.To see where packets that leave your router for a particular destination go, and how far, use the
trace
command.
ExampleName#trace
xx.xx.xx.xx
It may take a few minutes for this utility to finish, so give it some time. It will display a list of all the hops it makes on the way to the destination.
debug
commands
There are several debug
commands provided by the IOS. These commands are not covered here. Refer to the
Cisco website for more information.www.cisco.com
No comments:
Post a Comment